---
title: "Lesson 2.2 - プリミティブなオブジェクトの作成と配置  "
content_type: tutorial
url: "https://learn.unity.com/tutorial/lesson-2-2-creating-primitive-objects-and-arranging-them-jp?language=ja"
language: ja
difficulty: beginner
duration_minutes: 45
unity_version:
  - "2019.4"
supported_unity_versions:
  - name: "2019.4"
    url: "https://learn.unity.com/tutorial/lesson-2-2-creating-primitive-objects-and-arranging-them-jp.md?language=ja&version=2019.4"
available_languages:
  - name: "en"
    url: "https://learn.unity.com/tutorial/lesson-2-2-creating-primitive-objects-and-arranging-them.md?language=en"
  - name: "ja"
    url: "https://learn.unity.com/tutorial/lesson-2-2-creating-primitive-objects-and-arranging-them-jp.md?language=ja"
  - name: "ko"
    url: "https://learn.unity.com/tutorial/sueob-2-2-peurimitibeu-obeujegteu-saengseong-mic-jeongryeol.md?language=ko"
last_updated: "2026-08-04T14:21:18.000Z"
---

# Lesson 2.2 - プリミティブなオブジェクトの作成と配置  

2D スケッチから出発し、2D 背景とプリミティブで奥行きとスケールを持つ 3D シティシーンをレイアウトします。

この授業では、2D の背景画像をいくつか配置し、プリミティブを使って周囲の街の建物をレイアウトすることで、2D のスケッチを 3D で実現します。

多くの場合、プリビズでは、レイアウトアーティストにシーンのスケッチやストーリーボードが提供されます。ここで、これらのアーティストは、シンプルなジオメトリの作成を通して、シーンの適切な奥行きとスケールを解釈し始めることができます。このシーンの最初のイテレーションは、下流の部門（従来、プリビズの後に来る部門、例えば、セット、キャラクター、ライティングなど）の作業と拡張のための基礎を設定します。

## Materials

- [CityBackground.zip](https://unity-connect-prd.storage.googleapis.com/20200622/ad0f6b24-7025-42e2-a318-e17555782786/CityBackground.zip)

## 1. 授業の概要

[Video](https://connect-mediagw.unity.com/h1/20200610/videos/61e6e2b3-78d9-4ed0-98a5-7145683a1d8c_2.2_v.02.mp4)

## 2. 視覚的なアンカーの作成：平面と背景

プリビズは、2 次元のリファレンスを 3D に変換する最初の段階です。平面画像に新たな次元を追加するのは大変な作業です。このプロセスを簡単にするために、Unity に内蔵されているプリミティブを使って、街並みのスケッチを大まかに近似してみましょう。

スケッチを 4 つのバラバラのチャンクに分けることができます：地面、遠景の建物、中景の高層ビル、そして前景の個性的なビル群 (**画像 01**).

![画像 01：街のスケッチ](https://connect-mediagw.unity.com/h1/20200530/learn/images/a233fbe4-ffcd-4d13-b35a-acc146d8a6a9_FirstImageScreen.PNG)

 まずは地上面と背景の建物を遮断することから始めてみましょう。それらはスケッチの最大の要素であり、小さな建物を相対的に配置するためのアンカーとしての役割を果たします。二次元のリファレンスが与えられたら、大きな図形をブロックしてから、より小さく、より詳細なオブジェクトに向かって作業するのがベストです。まずは基本的なことから始めましょう。

**1.** 左上隅のメニューバーで、**GameObject > 3D Object > Plane** の順に選択します。新しい Plane ゲームオブジェクトが Hierarchy に追加され、シーンに配置されます (**画像 02**)。

**2.** Inspector で、Transform Scale を X:20、Y:1、Z:20 に設定します。

![画像 02：シーン上の平面](https://connect-mediagw.unity.com/h1/20200622/learn/images/131774f5-f650-4b03-b950-759b3c49f0ed_image5.png)

ゲームオブジェクトは、キャラクター、小道具、風景を表現する Unity の基本的なオブジェクトです。

**3.** Plane ゲームオブジェクトの色が茶色になっていることに気づくかもしれません。Hierarchy で、Directional Light を選択します。Inspector で、Light コンポーネントの Color Picker を選択し、色を白に変更します (**画像 03**).

![画像 03：Color Picker を白に設定する](https://connect-mediagw.unity.com/h1/20200622/learn/images/90f3bb81-04d9-4b9f-a875-307b7d09ded1_image17.png)

**4.** Directional Light が選択されたままの状態で、 Inspector Transform コンポーネントの回転を X:60、Y:90、Z:90 に変更します。Directional Light については、この Unit で後ほど詳しく説明します。

デフォルトでは、すべてのゲームオブジェクト（Cubesなど）は自動的に Transform コンポーネントを持っています。Transform は、ゲームオブジェクトの位置と、回転とスケール（拡大/縮小）の方法を指定します。

**5.** [こちら](https://connect-prd-cdn.unity.com/20200714/184294a1-4aed-4d02-98ad-722a358ff87a/CityBackground.zip?_ga=2.230939801.789509599.1594721815-549233092.1585830599)から CityBackground.zip をダウンロードし、フォルダーを解凍します。

**6.** Unity で Project ウィンドウを開き、Assets > Import Package > Custom Package を右クリックします。CityBackground.assetpackage を選択し、Import を選択します。

**7.** Project ウィンドウから **Assets > Prefabs** の順に移動し、Project ウィンドウから CityBackground Prefab を Scene ビューにドラッグします。

**8.** Hierarchy で CityBackground を選択し、Inspector の位置を X:45, Y:25, Z:0 に設定します。

**9.** 移動ツール、軌道ツール、そしてズームツールを使用して、Scene ビューを以下の画像に似たものにします (**画像 04**)。Unity の使用経験がない場合や、復習が必要な場合は、[Scene ビューでの移動、軌道、ズームについて](https://docs.unity3d.com/Manual/SceneViewNavigation.html#tools)のクイックガイドをお読みください。

![画像 04：アンカーが配置されたこれまでのシーン](https://connect-mediagw.unity.com/h1/20200622/learn/images/6eb2e195-96a3-4ddf-8d6d-1fe851da08f0_image10.png)

## 3. 中間要素の作成：高層ビル

次に高層ビルを作ります。シンプルな形状のため、いくつかの Cube プリミティブを使ってブロック化することができます。プリミティブとは、Unity の内部で直接作成できるオブジェクトのことです。 Unity にはいくつかのプリミティブオブジェクトの型があります。 この授業では、主に Cube を使用しますが、他のオプションには、Sphere、Capsule、Cylinder が含まれます。

**1.** **GameObject > 3D Object > Cube** の順に移動します。新しい Cube ゲームオブジェクトが Hierarchy に追加され、シーンに配置されます。

**2.** Scene ビューにマウスカーソルを合わせ、Cube を選択した状態で、キーボードの「F」キーを押すと、ビューが Cube に再フォーカスされます (**画像 05**)。

![画像 05：シーンに Cube を追加します。現在はシーンの残りの部分と比較してかなり小さいです。](https://connect-mediagw.unity.com/h1/20200622/learn/images/709d1b35-b59e-4ee2-8f7b-4d058cba608a_image20.png)

Scene ビュー内で Cube を自由に操作できるようになりました。オートデスクの Maya など DCC (Digital Content Creation) パッケージに慣れている人には、Unity の Scene ビューは Maya のビューポートと似たような機能を持っています。

Maya と同じホットキーを使って、Cube を平行移動したり回転させたりすることができます。参考までに、ホットキーは以下の通りです：

> W：移動ツール：シーン上の Cube を変形させる

> E：回転ツール：Cube を軸に沿って回転させる

> R：スケールツール：Cube を一様に、または個々の軸に沿ってスケールする

**3.** Cube を選択した状態で、W、E、R のホットキーを使って変形、回転、スケール（拡大・縮小）を試してみてください。これらのキーに慣れておくことは、このコースを通して非常に役立ちます。

**4.** Cube を平面上の左側に配置することから始めます。変形/回転/スケールツールを使って、Cube の上部をシーン内の背景要素の上部に合わせてみてください。次のステップでは、正確なスケールを提供するので、正確であることを心配する必要はありませんが、これらのツールのそれぞれがどのように動作するかを理解するために時間がかかります (**画像 06**)。

![画像 06：背景の建物の高さに合わせて Cube を配置し、スケーリングする](https://connect-mediagw.unity.com/h1/20200622/learn/images/b8df6747-c516-44a3-87d7-ba93cd82838d_image2.png)

**5.** Cube を選択したまま、そのスケールを X:8, Y:42, Z:8 に設定します。

この Cube は、Maya を使用したことのある方ならお馴染みの別のショートカットを使用して、街並みを構成する他の 4 つの高層ビルにも複製することができます。

**6.**  Scene ビューまたは Hierarchy で Cube を選択した状態で、Ctrl/Cmd + D を押して、さらに 4 回複製します。コントロールを追加するには、Ctrl/Cmd キーを押しながら、これらの新しい Cube を変換し、以前に作成された平面にスナップされた各 Cube を保持します。複製した後、縦と横にスケーリングして高さと幅を交互に変化させます (**画像 07**)。

![画像 07：街の背景や中景の要素でこれまでのものをビジュアル化したもの](https://connect-mediagw.unity.com/h1/20200622/learn/images/9397e76d-e47a-43c6-92dd-adc252105341_image16.png)

**7.** (**画像 08**) のように、各建物を互い違いに配置する

![画像 08：互い違いに配置された Cube](https://connect-mediagw.unity.com/h1/20200622/learn/images/da5f4455-adef-4654-b67d-641f2b765913_image3.png)

シーンを展開し、Hierarchy でより多くのオブジェクトを作成していると、すぐにわかるように、整理しておくことが非常に重要になります。

**8.**  Hierarchy で **Create** を選択し（+ 記号です）、Empty ゲームオブジェクトを作成し、そのゲームオブジェクトの名前を _Highrises_ に変更します。次に、先ほど作成した 5 つの高層ビルを新しいゲームオブジェクトの下に入れ子にし、それぞれを Highrises ゲームオブジェクトの上にドラッグアンドドロップします (**画像 09**)。

![画像 09：Cube が入れ子になっている Highhrise ゲームオブジェクト](https://connect-mediagw.unity.com/h1/20200622/learn/images/90a1e4b3-f114-4624-9dad-f8fb1a79ca7d_image14.png)

Unity では、Highrises ゲームオブジェクトが親ゲームオブジェクトとみなされ、その下にある Cubes が子ゲームオブジェクトとみなされるようになりました。（Hierarchy については [こちら](https://docs.unity3d.com/Manual/Hierarchy.html)をご覧ください）。 これで、Unityでオブジェクトを作成する2つの方法がわかりました。1 つは、トップメニューで ゲームオブジェクトを選択してください。もう一つは、Hierarchy の中にある Create ボタン（＋記号）を使ったものです。

## 4. 立体的な高層ビルをつくる

参考文献を見ると、高層ビルの間には複数階建ての建物があるようです。これを高層ビルと呼ぶことにしましょう (**画像 10**)。

![画像 10：複数の Cube から、これらの追加の高層ビルのセットを作成することができます。](https://connect-mediagw.unity.com/h1/20200530/learn/images/081dfaa1-3ac9-4e4a-8b36-43a5e6a1e75c_image11.png)

**1.** 別の Cube を作成し、スケールを X:4、Y:30、Z:4 に設定して 4 回複製します。各 Cube の Y の高さを 10～30 の間で変化させます。下のような形になるまで、各 Cube をスケールして配置します (**画像 11**)。

![画像 11：高層ビルがどのように見えるかの例](https://connect-mediagw.unity.com/h1/20200622/learn/images/636c5676-a872-45f7-bc4b-a5b091579994_image6.png)

**2.** Hierarchy では、Empty 作成し、その名前を _Multi-Highhrise_ に変更します。次に、その下に _Multi-Highhrise_ を構成する 5 つの新しい Cube を入れ子にします (**画像 12**)。

![画像 12：Hierarchy での高層ビル（multi-level highrise）の見え方](https://connect-mediagw.unity.com/h1/20200622/learn/images/86889107-6bb8-4cf3-830b-0fef71198357_image12.png)

**3.**  今すぐ Hierarchy 内のこの親ゲームオブジェクトを 4 回複製して、構造体をスケーリングして、Cube を個別に変更する必要があるのではなく、グループとして配置することができるようにします。

**4.**  各高層ビル構造物を大まかに図のように配置します (**画像 13**)。

![画像 13：シーン内に配置された高層ビル群](https://connect-mediagw.unity.com/h1/20200622/learn/images/3c7e9536-e690-48da-8f8d-68492eb13c72_image18.png)

**5.** シーン内の建物が離れていることに注意してください。建物を近くに移動させて、より密度の高い街を形成しましょう。

**6.** 次に、高層ビルをスケールして回転させます。これらの新しい建物をスケールしたり回転させたりすることで、実際の都市のように様々な階層や形を持つスカイラインを素早く構成することができます (**画像 14**)。

![画像 14：都市の景観が街並みらしくなってきました](https://connect-mediagw.unity.com/h1/20200622/learn/images/0d202440-b2bc-4923-8714-89e40f56b5d3_image1.png)

**7.** 作業を保存します。**File > Save** に移動します。

## 5. ユニークな建物の識別と遮断

高層部と背景が整ったので、前景を構成する残りの建物を遮る準備ができます。前景の建物を作ることで、あなたの整理できる能力が試されます。オブジェクトの位置は、私たちと全く同じである必要はありませんが、キューブ (Cube) のスケールに固執しようとする必要がないことに留意してください。

**1.**  手前の建物が多いので、大きさ別に整理していきます。空のゲームオブジェクトを 6 つ作成し、次の名前を付けます：_LargeForegroundBlds_, _LargeForegroundBlds2_, _MediumForegroundBlds_, _MediumForegroundBlds2_, _SmallForegroundBlds_, _SmallForegroundBlds2_

**2.** X:15、Y:16、Z:15 のスケールで最大の Cube を作成します。これを 3 回複製して、画像 16 のようにおおよその位置に配置します (**画像 16**). 3 つの Cube を親のゲームオブジェクト LargeForegroundBlds に入れ子にします。

![画像 16：手前にある最も大きな建物](https://connect-mediagw.unity.com/h1/20200622/learn/images/5708473b-cba1-4a0f-86a4-6062de34012f_image7.png)

**3.** X:7、Y:15、Z:10 のスケールで次の最も大きい Cube を作成します。3 回重ねて、ほぼ画像のように配置します (**画像 17**)。親の LargeForegroundBlds2 に 3 つの Cube を入れ子にします。

![画像 17：手前の大きな建物の第 2 セット](https://connect-mediagw.unity.com/h1/20200622/learn/images/a0ba7aa7-46ff-46c9-aa43-ee43fb15bb9c_image21.png)

**4.** X:7, Y:7, Z:14 のスケールで中くらいの大きさの Cube を作成します。それを 3 回複製して、ほぼ画像のように配置します (**画像 18**)。3 つの Cube を親の MediumForegroundBlds に入れ子にします。

![画像 18：手前の中くらいの大きさの建物](https://connect-mediagw.unity.com/h1/20200622/learn/images/8596f762-4a45-49f9-907e-b1f1038c7fc5_image15.png)

**5.** 次の中くらいの Cube を X:10 Y:4 Z:17 のスケールで作成します。それを 3 回複製して、ほぼ画像のように配置します (**画像 19**)。親の MediumForegroundBlds2 に 3 つの Cube を入れ子にします。

![画像 19：前景にある中くらいの建物の第 2 セット](https://connect-mediagw.unity.com/h1/20200622/learn/images/81361167-5a89-4962-babe-c1edfc2c5426_image13.png)

**6.** X:6 Y:8 Z:6 のスケールで小さな Cube を作成します。それを 4 回複製して、ほぼ画像のように配置します (**画像 20**)。親の SmallForegroundBlds に 5 つの Cube を入れ子にします。

![画像 20：手前の小さな建物](https://connect-mediagw.unity.com/h1/20200622/learn/images/70692922-85ce-48d1-bcf4-a4cecc6a0b7b_image8.png)

**7.** 次に X:7 Y:5 Z:8 のスケールで小さな Cube を作成します。2 回複製して、画像のようにおおよその位置に配置します (**画像 21**)。親の SmallForegroundBlds2 に 2 つの Cube を入れ子にします。

![画像 21：手前の小さな建物の第 2 セット](https://connect-mediagw.unity.com/h1/20200622/learn/images/6cb69b49-9e39-4f06-a20e-110b052ef14d_image4.png)

**8.** 最後になりましたが、Hierarchy が整理されていることを確認してください (**画像 22**)。

![画像 22：よく整理された Hierarchy](https://connect-mediagw.unity.com/h1/20200622/learn/images/e90c47dc-3953-4da3-b377-fa5cee3db7e4_image9.png)

## 6. 簡単なまとめ

プリミティブオブジェクトは、より複雑なジオメトリの基礎となります。プリミティブオブジェクトを使用して、2D スケッチを 3D で解釈し始める方法を学びました。しかし、それだけではそれほど進展が見られません。 次の授業では、これらのオブジェクトを修正して、より面白い形を作る方法を学びます。
