---
title: "Lesson 7.3 - タイトル"
content_type: tutorial
url: "https://learn.unity.com/tutorial/lesson-7-3-titles-jp?language=ja"
language: ja
difficulty: beginner
duration_minutes: 50
unity_version:
  - "2020.2"
  - "2020.1"
  - "2019.4"
  - "2019.3"
supported_unity_versions:
  - name: "2020.2"
    url: "https://learn.unity.com/tutorial/lesson-7-3-titles-jp.md?language=ja&version=2020.2"
  - name: "2020.1"
    url: "https://learn.unity.com/tutorial/lesson-7-3-titles-jp.md?language=ja&version=2020.1"
  - name: "2019.4"
    url: "https://learn.unity.com/tutorial/lesson-7-3-titles-jp.md?language=ja&version=2019.4"
  - name: "2019.3"
    url: "https://learn.unity.com/tutorial/lesson-7-3-titles-jp.md?language=ja&version=2019.3"
available_languages:
  - name: "en"
    url: "https://learn.unity.com/tutorial/lesson-7-3-titles.md?language=en"
  - name: "ja"
    url: "https://learn.unity.com/tutorial/lesson-7-3-titles-jp.md?language=ja"
  - name: "ko"
    url: "https://learn.unity.com/tutorial/sueob-7-3-jemog.md?language=ko"
last_updated: "2026-08-04T14:23:36.000Z"
---

# Lesson 7.3 - タイトル

プロジェクト内にオンスクリーンのタイトルを追加し、見せ方を整える方法を学びます。

すべての映画にはタイトルがあります。この授業では、プロジェクトにタイトルを追加する方法をご紹介します。

## 1. 授業概要

[Video](https://connect-mediagw.unity.com/h1/20200715/videos/67c6774c-2916-4a29-bc6f-e412df35bb3c_7.3_Creating_Titles.mp4)

## 2. TextMeshPro のインストール

**TextMesh Pro** は、Unity でスタイリッシュなテキストを作成できるパッケージです。TextMesh Pro に不可欠なリソースとフォントをプロジェクトにインポートします。

**1.** トップメニューのドロップダウンから選択します：**Window > Text Mesh Pro > Import TMP Essential Resources** の順に選択します（**画像 01**）。

![画像 01：TMP Essential Resources のインポート方法](https://connect-mediagw.unity.com/h1/20200715/learn/images/95d40ed0-e35f-4c2f-abe3-ea478c808490_image.png)

**2.** TextMesh Pro パッケージ全体が選択されていることを確認し、Import をクリックします（**画像 02**）。

![画像 02：パッケージをインポートするためにチェックしなければならないボックス](https://connect-mediagw.unity.com/h1/20200715/learn/images/5e98141e-de25-468b-8bcc-3d61d9c073cb_image.png)

**3.** トップメニューのドロップダウンから、以下の順に選択します：

**Window > TextMeshPro > Import TMP Examples and Extras** (**画像 03**).

![画像 03：TMP フォントのインポート方法](https://connect-mediagw.unity.com/h1/20200715/learn/images/4792f394-0a42-4d60-8ead-e622fa7d22aa_image.png)

**4.** ここで必要なのは **Fonts** パッケージだけです。TextMesh Pro のボックスのチェックを外して、不要なボックスの選択を解除します。フォント パッケージのみを選択するために、Fonts ボックスにチェックを入れ、Import をクリックします (**画像 04**)。

![画像 04：フォントのみを選択した場合の TMP Examples と Extras](https://connect-mediagw.unity.com/h1/20200715/learn/images/afdb82b2-0515-49a3-aada-47b1005fc22d_image.png)

## 3. テキストの追加とスタイリング 

プロジェクトに必要なツールが揃ったので、いよいよタイトルを作成しましょう。**Bangers** というフォントを使用します。まず、**Font Asset** を作成します。

**1.** Assets の中の TextMesh Pro フォルダーに移動して、 **Examples and Extras > Fonts > Bangers** の順に移動して、新しい Font Asset を作成します （**画像 05**）。

![画像 05：Fonts フォルダー内の Bangers](https://connect-mediagw.unity.com/h1/20200715/learn/images/2408e44d-09b2-4805-82d0-bafb8e397322_image6.png)

**2.** Bangers を右クリックして **Create > TextMesh Pro > Font Asset** の順に選択します（**画像 06**）。

![画像 06：Font Asset の作成方法](https://connect-mediagw.unity.com/h1/20200715/learn/images/d50cee2c-1f12-4318-9cd5-27a61ad7ed43_image46.png)

これにより、Fonts フォルダー内に「Bangers SDF」(**画像 07**) という新しい Font のアセットが作成されます。

![画像 07：Bangers フォントの上に Bangers SDF がある](https://connect-mediagw.unity.com/h1/20200715/learn/images/a2a98a79-c7ee-481e-b33a-13e6b6b92c92_image10.png)

これで Font アセットが利用できるようになったので、タイトル自体を作成します。

**3.** Hierarchy の中で右クリックし、**UI > Text - TextMeshPro**（**画像 08**）の順に移動して、シーンに新しい TextMesh Pro ゲームオブジェクトを作成します。

![画像 08：TextMesh Pro ゲームオブジェクトの作成方法](https://connect-mediagw.unity.com/h1/20200715/learn/images/7a531944-6982-4dbf-ab3e-fb15f143442f_image7.png)

これで Game ビューにテキストが表示されるはずです(**画像 09**)。

![画像 09：Game ビュー内のテキスト](https://connect-mediagw.unity.com/h1/20200715/learn/images/6b07dde9-fdbe-4394-a5a5-4062b6e4949f_image37.png)

**4.** このステップでは、テキスト（TMP）ゲームオブジェクトの親となる **Canvas** も作成します。 これを 「TitleCanvas」という名前に変更します (**画像 10**)。

![画像 10：Hierarchy 内の TitleCanvas](https://connect-mediagw.unity.com/h1/20200715/learn/images/91261ff0-9cdd-4c0e-a1e7-0a91f7c4c758_image41.png)

- TitleCanvas が選択されていることを確認します。**Canvas Scaler** の Inspector で **UI Scale Mode** を  **Constant Pixel Size** から **Scale With Screen Size** に変更して、タイトルを 16:9 のアスペクト比に比例した比率に保つようにします (**画像 11**)。

![画像 11：Canvas Scale Factor を Scale With Screen Size へ変更する方法](https://connect-mediagw.unity.com/h1/20200715/learn/images/776e0c72-a06b-43cf-b689-31445664d36d_image31.png)

**5.** **Canvas Scaler** の下の **Reference Resolution** を **X: 1920 Y: 1080** に変更し、タイトルが画面解像度に比例して中央に配置されたままになるように、**Match** の値を **0.5** に変更します (**画像 12**)。

![画像 12：Canvas Scaler の設定を調整する方法](https://connect-mediagw.unity.com/h1/20200715/learn/images/3dbaff03-eb2b-43c7-ab63-78cd62fe56cc_image18.png)

**6.** Hierarchy ウィンドウに戻り、**Text (TMP)** の名前を「Title」に変更します (**画像 13**)。

![画像 13：Title ゲームオブジェクト](https://connect-mediagw.unity.com/h1/20200715/learn/images/e201c783-df0e-42f9-b8f0-88daf99aee2d_image21.png)

**7.** Inspector で、**TextMeshPro - Text (UI)** に移動し、「New Text」を「The Chase」に変更します (**画像 14**)。

![画像 14：テキストの変更する場所](https://connect-mediagw.unity.com/h1/20200715/learn/images/142ce1d7-7598-44a8-aed9-1aa42d9fa2af_image23.png)

8\. **Rect Transform** の下で、Width を **1280** に、Height の値を **250** に変更します（**画像 15**）。これにより、タイトルが画面上の transform position に均等にスケーリングされるようになります。さらに、画面上の必要な位置にタイトルを配置するために、X と Y の position の値を 0 に変更します。

![画像 15：Rect Transform の値を変更する](https://connect-mediagw.unity.com/h1/20200715/learn/images/ebbcb826-c79a-41fa-8847-cc79e1e818aa_image20.png)

9\.  **Anchor Presets** で、**center**、**middle** のボックスをクリックして、タイトルをビューの中央に配置したままにします(**画像 16**)。

![画像 16：Center、Middle の Anchor Preset](https://connect-mediagw.unity.com/h1/20200715/learn/images/260b371b-13d6-4d2e-9005-64174680b19e_image48.png)

この時点で、タイトルは以下のようになります (**画像 17**)。まだ中央に表示されていないことに注意してください。これはサイズを大きくすれば変わるでしょう：

![画像 17：設定が更新されたタイトル](https://connect-mediagw.unity.com/h1/20200715/learn/images/f3171f4b-2a01-4f8a-808d-c121f3f69fa7_image12.png)

タイトルアセットを作成したら、次は美的なデザインのタイトルに匹敵するようにアメコミ調のスタイライズドな表現をするような見え方にしましょう。

**10.** Inspector の TextMesh Pro - Text (UI) タブに戻ります（**画像 18**）。

- **Font Asset** を Bangers SDF に変更します。
- **Font Size** を 250 に変更します。
- **Vertex Color** を変更してフォントの色を 1 色にするか、**Color Gradient** を有効にしてグラデーションを使用することができます。このチェックボックスを有効にして、1 色目を「#FFD900FF」、2 色目を「#FF006FFF」、3 色目を「#FF005BFF」、4 色目を「#A500FFFF」にしました。
- **Alignment** を中央に変更します。

![画像 18：設定を調整した TextMesh Pro - Text (UI) セクション](https://connect-mediagw.unity.com/h1/20200715/learn/images/418f96ff-e3f8-414f-85c8-09f6a702c10a_image4.png)

結果は以下のようになるはずです（**画像 19**）。

![画像 19：基本的な調整を行ったタイトル](https://connect-mediagw.unity.com/h1/20200715/learn/images/5c08ce54-cc5f-4818-a5a3-088a7b143481_image45.png)

**11.** Inspector で、Extra Settings の下にある **Bangers Atlas Material** の三角形を展開し、**Face** と書かれた設定で、**Color** を**ライトピンク**に変更し、**Dilate** の値を **0.5** に変更します（**画像 20**）。このようにすると、タイトルが大きく表示され、文字が重なります。

![画像 20：Extra Settings の調整](https://connect-mediagw.unity.com/h1/20200715/learn/images/d425f49b-3244-42ba-8a24-94f52fe01bd3_image15.png)

結果はこのようになります (**画像 21**) ：

![画像 21：前のステップからの変更結果](https://connect-mediagw.unity.com/h1/20200715/learn/images/3ed8a5db-3fb5-45d0-a735-349fc724cc5f_image5.png)

**12.** テキストの周りに 3 色の境界線を作成すると、テキストがパッと現れるのに役立ちます (**画像 22**)。

- **Outline** の **Color** を **Navy Blue** に変更し、**Thickness** の値を **0.7** に変更します。Outline とは、テキストの外縁と一番外側の境界線要素のことです。
- Underlay は、一番内側のボーダー要素です。Underlay チェックボックスを有効にしてから、もう一度 Underlay フィールドを選択してプロパティを展開します。Underlay の色を **Purple**（**Color** 設定の **Alpha** が **255** に設定されていることを確認してください）、**Offset  X** を **0.15**、**Offset Y** を **0.2**、**Dilate** の値を **0.62**、**Softness** の値を **0.07** に変更します。
- Glow は、Outline と Underlay の中間の色です。Glow チェックボックスを有効にしてから、再度 Glow フィールドを選択してプロパティを展開します。Glow の色を **Turquoise** に変更し、**Alpha** を **255** に設定します。**Offset** の値を **1**、**Inner** の値を **0.255**、**Outer** の値を **0.7**、**Power** 値を **0.3** に設定します。

![画像 22：タイトルの周りに境界線を作成するために必要な追加設定](https://connect-mediagw.unity.com/h1/20200715/learn/images/4dc4d801-2b13-4ce0-9ec7-26613205cf13_image11.png)

タイトルは以下のようになります（**画像 23**）：

![画像 23：完成したタイトル](https://connect-mediagw.unity.com/h1/20200715/learn/images/4f8ad659-a8d6-4bf0-816e-5052c2a8a508_image1.png)

TextMesh Pro は、テキストのスタイリングに多くの柔軟性を提供します。さらにいっそうユニークに見えるようにしたい場合は、タイトルの設定を試してみてください。


## 4. テキストのフェードイン/フェードアウト

これで定型化されたタイトルが完成しました。映画の最初にタイトルをフェードインしたりフェードアウトしたりしてみましょう。**opacity**（不透明度）や **alpha channel** の値をアニメーション化することでフェードインとフェードアウトを行います。まず、タイトルの **Animation Track** を作成します。

**1.** Timeline ウィンドウで右クリックして、新しい **Track Group** を作成します（**画像 24**）。

![画像 24：Timeline ウィンドウで右クリックして、新しい Track Group を作成](https://connect-mediagw.unity.com/h1/20200715/learn/images/0a1c26e9-8d67-4fe0-b003-149e649fd76e_image38.png)

**2.** Track Group の名前を「Title Group」に変更します。

**3.** タイトルの Title Group に Animation Track を追加します（**画像 25**）。

![画像 25：Title Group へのアニメーショントラックの追加](https://connect-mediagw.unity.com/h1/20200715/learn/images/e88c6a93-414f-4571-8f85-9d35be44d922_image30.png)

**4.** Hierarchy 内の「Title」ゲームオブジェクトを空のアニメーショントラックにドラッグして、**Create Animator on Title** をクリックします（**画像 26**）。

![画像 26：アニメーショントラックを「Title」に割り当てる](https://connect-mediagw.unity.com/h1/20200715/learn/images/5ad2d7c8-3816-405d-9743-bcecfbb153c4_image22.png)

タイトルのアニメーショントラックができたので、その不透明度をアニメーション化します。

**5.** 赤色の録画ボタンをクリックすると、タイトルのアニメーションが始まります。

![画像 27：録画ボタン](https://connect-mediagw.unity.com/h1/20200715/learn/images/5cc61c22-7f64-4cee-81a2-783d6a5f5665_image16.png)

**6.** Timeline の再生ヘッドカーソルが Frame 0 に設定されている状態で、Hierarchy ウィンドウで「Title」ゲームオブジェクトが選択されていることを確認します。次に、TextMeshPro - Text（UI）コンポーネント内の Inspector ウィンドウで Vertex Color を選択します（**画像 28**）。

![画像 28：TextMeshPro - Text (UI) 下の Vertex Color](https://connect-mediagw.unity.com/h1/20200715/learn/images/f4ab8cde-ac3e-46ec-a977-aa866185fe4f_image26.png)

**7.** **A (alpha)** の値を **0** に変更して、タイトルを透明にします（**画像 29**）。

![画像 29：Color の A の値を調整する場所](https://connect-mediagw.unity.com/h1/20200715/learn/images/f19df1a7-aa95-40cd-97bb-8e2126982fcb_image3.png)

**8.** Timeline で、Frame 番号 20 に向かってスクラブし、タイトルの alpha 値を **255** に戻して再び表示するようにします。これで、タイトルは完全にクリアな状態からフェードインします（**画像 30**）。

![画像 30：約 20 Frame で 255 に戻ったアルファ値](https://connect-mediagw.unity.com/h1/20200715/learn/images/1935b810-496f-433a-a2d2-70c0ed0c8243_image24.png)

**9.** Graph エディターで個々のキーの時間と値を調整することで、タイトルのフェードインの見え方をさらに調整することができます。これは、キーを右クリックして **Edit Key** を選択することで実行できます。フェードイン時間を長くするために、キーの開始時間を **20 フレーム**インから **35 フレーム**インに変更してみてください (**画像 31**) と (**画像 32**)。

![画像 31：Graph エディターでの個々のキーの調整](https://connect-mediagw.unity.com/h1/20200715/learn/images/392a0598-d40f-4503-943b-171f8ed85157_image47.png)

![画像 32：2 番目のキーフレームを 35 フレームインに移動して、フェードインがより長い時間にわたって発生するようにしました](https://connect-mediagw.unity.com/h1/20200715/learn/images/b3430317-88cc-452c-8107-2bac840a741e_image34.png)

タイトルがフェードインしてきたので、アクションが始まったらフェードアウトしましょう。

**10.** Timeline を 約 **81** フレームインにスクラブし、Graph エディターを右クリックして新しいキーを追加します（**画像 33**）。これにより、タイトルと同じ **255** **alpha 値**の新しいキーフレームが追加されるはずです。

![画像 33：新しいキーを追加してフェードアウトを開始する](https://connect-mediagw.unity.com/h1/20200715/learn/images/4652c507-b764-45da-9e51-54c1d637e198_image17.png)

**11.** **89** フレームインほど前にスクラブし、タイトルのアルファ値を **0** に変更してフェードアウトを作成します（**画像 34**）。

![画像 34：アルファ値を 0 に設定すると、タイトルのフェードインとフェードアウトが可能になります](https://connect-mediagw.unity.com/h1/20200715/learn/images/13d76404-80ce-4a12-9c17-a0e2db9ebb10_image13.png)

フェードアウトの設定を調整することで、より緩やかに見えるようになり、映像制作のタイミングに合わせた演出ができるようになりました。

**12.** 3 番目のキーフレームを右クリックして、**Edit Key** を選択し、時間を **65** フレームに変更します。4 番目のキーフレームを右クリックして、**Edit Key** を選択し、時間を **75** フレームに変更します（**画像 35**）。

![画像 35：キーを右クリックしてキーフレームの設定を変更する](https://connect-mediagw.unity.com/h1/20200715/learn/images/d679fc25-ca38-45ce-a18e-33b8c88be467_image39.png)

**13.** このアニメーションの編集を終了するには、点滅する赤色の丸ボタンをクリックして保存してください（**画像 36**）。

![画像 36：録画ボタンをもう一度クリックして録画を終了する](https://connect-mediagw.unity.com/h1/20200715/learn/images/65a70225-224e-4b7e-866f-b72433d3e17e_image44.png)

**14.** また、タイミングが合うようになるまで遷移をクリックしてドラッグすることで、さらに調整することもできます（**画像 37**）。最終的なキーフレームを **85** フレームまでドラッグしてみてください（**画像 38**）。

![画像 37：録画終了後のアニメーションの調整](https://connect-mediagw.unity.com/h1/20200715/learn/images/969621f3-1fed-450b-86b2-6f157dedf97f_image27.png)

![画像 38：最終キーフレームを frame 85 に戻す](https://connect-mediagw.unity.com/h1/20200715/learn/images/aaa2c127-f713-4609-aae0-0e640aeebe5d_image27.png)

## 5. ビデオのフェードイン/フェードアウト

最後に、作品の最初と最後にフェードインとフェードアウトを追加します。これを行うには、タイトルで行ったように、黒のイメージを作成し、その不透明度 (opacity) を調整します。

まず、キャンバスを覆うような黒い画像を作成します。

**1.** Hierarchy で、**TitleCanvas** を右クリックし、 **UI > Image** の順に選択します（**画像 39**）。

![画像 39：黒の画像の作成](https://connect-mediagw.unity.com/h1/20200715/learn/images/921021fd-889a-43da-96c0-c25ea40472b3_image28.png)

これにより、TitleCanvas の子である **Image** ゲームオブジェクトが作成されます（**画像 40**）。

![画像 40：Hierarchy 内の Image ゲームオブジェクト](https://connect-mediagw.unity.com/h1/20200715/learn/images/47d5e4b3-e8e4-4efd-81a8-91ef1141de44_image42.png)

**2.** Inspector で、Rect Transform の下の **Anchor Presets** を **Stretch**、**Stretch**に変更し、**Alt/Option**キーと **Shift** キーを押しながら画像を拡大して、ビュー全体に収まるようにします（**画像 41**）。すると、すぐに白い画像が Game ビュー全体を覆っているのがわかるはずです。

![画像 41：Anchor Preset を stretch、stretch に変更](https://connect-mediagw.unity.com/h1/20200715/learn/images/c7cc16a7-8772-4ff4-bf60-b33be1111b00_image19.png)

**3.** 以下の Image の下で、色を**白**から**黒**に変更します (**画像 42**)。これにより、Game ビューの色が白から黒に変わります。

![画像 42：Image の色を黒に変更](https://connect-mediagw.unity.com/h1/20200715/learn/images/d394da4f-a149-483d-98d8-a65631d09f07_image14.png)

**4.** ここで Image の名前を「**FadeInToBlack**」に変更します（**画像 43**）。

![画像 43： Image の新しい名前「FadeInToBlack」](https://connect-mediagw.unity.com/h1/20200715/learn/images/bcc43fcc-af76-48f1-bd6b-53b56da3cd98_image25.png)

これで黒い画像ができました。タイトルと同じように、その不透明度 (opacity) をアニメーション化してフェードインとフェードアウトを作成しましょう。

**5.** Timeline で、Title Group を右クリックし、**Add Animation Track** を選択します（**画像 44**）。

![画像 44：Add Animation Track の設定](https://connect-mediagw.unity.com/h1/20200715/learn/images/109e1054-a8fe-4e24-9561-87ddfd73a8e5_image8.png)

FadeToBlack ゲームオブジェクトの Inspector で値を変更しながら作成した新しいアニメーショントラックを編集するには、Timeline の右上隅にある鍵のアイコンをクリックしてロックします（**画像 45**）。

![画像 45：Timeline をロックする方法](https://connect-mediagw.unity.com/h1/20200715/learn/images/e572b7a4-33bc-4552-9ea2-ccfb3c117d2c_image2.png)

**6.** FadeInToToBlack を空のアニメーショントラック上にドラッグして、**Create Animator on FadeInToBlack** を選択します (**画像 46**)。

![画像 46：空のアニメーショントラックを FadeInToBlack に割り当てる](https://connect-mediagw.unity.com/h1/20200715/learn/images/9f3d4a29-d955-4e0d-b272-3b7badad0613_image36.png)

**7.** 録画ボタンを押して、FadeInToBlack ゲームオブジェクトの不透明度 (opacity) をアニメーションさせます。

   **a.** Timeline を 0 frames にスクラブし、Image の下の Inspector で色をクリックして、A（alpha 値）を **255**に変更します（**画像 47**）。

![画像 47：FadeInToBlack の alpha 値を調整する場所](https://connect-mediagw.unity.com/h1/20200715/learn/images/c25f799a-0fc6-48d0-8faf-5ab1f6552200_image43.png)

   **b.** **10 frames** にスクラブし、A 値を **0** に変更します。 これでビデオはフェードインします。

   **c.** フェードアウトするには、frame **485** の**フレーム**で新しいキーを作成し、FadeInToBlack の alpha 値が 0 のままであることを確認します。

   **d. 515 フレーム**で最終フレームを作成し、FadeInToBlack のalpha 値を **255** に設定します。フェードアウトは、Graph エディター上ではこのように表示されるはずです（**画像 48**）。フェードインとフェードアウトをどの程度思い切ったものにするかによって、これらの値を自由に調整してください。

![画像 48：映像がフェードアウトしたときの Graph エディターと Game ビュー](https://connect-mediagw.unity.com/h1/20200715/learn/images/a95ca023-0a10-4279-a3c2-1bbd103e1809_image33.png)

## 6. まとめ

この授業では、TextMesh Pro を使ってスタイリッシュなタイトルを作成する方法と、Timeline を使ってタイトルとビデオ自体をフェードインおよびフェードアウトする方法を学びました。
